当前位置:首页 » python教程 » 正文

python3.7.3版本和django2.2.3版本是否可以兼容

283 次  2020-10-06  分类 : python教程

很多小伙伴在学习Django的时候,总是搞不定版本的问题,下面来一起看一张表,轻松解决Python版本和Django版本的兼容问题。

Django和Python兼容对照表

如上表所示:

  • Django 1.11版本兼容Python 2.7、3.4、3.5、3.6、3.7(added in 1.11.17)
  • Django 2.0版本兼容Python 3.4、3.5、3.6、3.7
  • Django 2.1、2.2版本兼容Python 3.5、3.6、3.7
  • Django 3.0版本兼容Python 3.6、3.7、3.8

大家按照上述对照表来选择Django和Python版本,以免造成不兼容等问题。

网友观点:

这个是老问题了,但是对任何时间刚开始学习Django的人都是一个必须搞清楚的问题。

根据官网的信息:

Django 版本 Python 版本

1.8 2.7, 3.2 (until the end of 2016), 3.3, 3.4, 3.5

1.9, 1.10 2.7, 3.4, 3.5

1.11 2.7, 3.4, 3.5, 3.6

2.0 3.4, 3.5, 3.6

2.1 3.5, 3.6, 3.7

重点是2017年底发布的2.0版将不再支持Python2!如果你的工作环境不强制指定版本,那么无论是从Python学习还是Django学习而言,Python3都是你最好的选择!

到此这篇关于python3.7.3版本和django2.2.3版本是否可以兼容的文章就介绍到这了,更多相关python3.7.3版本和django2.2.3版本兼容吗内容请搜索python博客以前的文章或继续浏览下面的相关文章希望大家以后多多支持python博客!

来源:python博客 欢迎分享!

本文链接:https://www.94e.cn/info/3758

标签:django  

<< 上一篇 下一篇 >>

  Powered By python教程网   鲁ICP备18013710号
python博客 - 小白学python最友好的网站!

扫一扫,关注微信公众号 扫一扫,关注微信公众号